OpenStreetMap "Access blocked"

Jun 7, 2010 at 6:25 PM

I'm getting this error message in the WPF sample app, some of the tiles are replaced with an error message saying: "Access Blocked we suspect this client is downloading maps in an unauthorized manner. Please ask at"


Is there a way to fix this, workaround, or somehow download the maps in an "authorized manner"?

Jun 7, 2010 at 7:17 PM
Edited Jun 7, 2010 at 7:29 PM

i never have such issue, unless you use 'server only' mode(p.s. that mode is created just for testing, use default settings)

Jun 8, 2010 at 3:25 AM

It was set to server + cache, but it was a fresh copy (the database was empty since it was the first time opening it on that machine)


Jun 8, 2010 at 5:48 AM

i've never blocked downloading few fresh tiles, did you use prefetcher? ;}

Jun 9, 2010 at 12:44 PM
I had used prefetcher in the past a few times, but it has been a couple months since I've last used the software... Like I said, this was as soon as I opened the program and it was viewing the initial "lietuva vilnius" location, it loaded a couple tiles then started loading a bunch of the "Access Blocked" tiles. I switched it to OpenStreetMapOSM and it started working. Maybe this was just a glitch in the OSM server and it was blocking people for incorrect reason?
Jun 9, 2010 at 12:47 PM

can you try directly ?

Jul 15, 2012 at 5:01 PM


today I got the first time the same message tiles from OSM.
I never used a prefetcher program and used OSM rarely.
The OSM page works fine on me computer.
Does GMap itentify it self against the server in the same way for all users ?
I mean then we all together may be a to heavy user.

Because of the message text I believe it's meat more against GMAP.NET, than against the user !
Please visit the webside named in the message:

Access blocked
This application is
blocked for overusing
volunteer-run servers:




Jul 16, 2012 at 8:00 AM
Edited Jul 16, 2012 at 9:11 AM

Hi All,

Started getting the same error today, what can we do?, we use a local SQL server so 80% of the requests are fine.

Can we use our own server?

Jul 16, 2012 at 9:46 AM

Yeah I'm getting that from Australia using the demo apps. My very quick test app also has the problem. The website works fine. 

So it seems they've identified the GMap.NET control and blocked it :(

Jul 16, 2012 at 1:44 PM

just change the useragent in GMapProvider.cs "public static string UserAgent = xxxx"

bye EDE

Jul 16, 2012 at 3:21 PM
Edited Jul 16, 2012 at 3:21 PM


      /// <summary>
      /// Gets or sets the value of the User-agent HTTP header.
      /// </summary>
      public static string UserAgent = "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20091221 Firefox/3.5.7";


Hi RobbeEDE!

What String shall I put as UserAgent?

Cheers, Xandolph

Jul 16, 2012 at 3:34 PM

Putting in a few random strings does not appear to help, I still get the blocked message!

Jul 16, 2012 at 3:36 PM
jamesscreech wrote:

Putting in a few random strings does not appear to help, I still get the blocked message!

Found a way, you need to set the value before you do anything else with the map control.

Jul 16, 2012 at 3:40 PM

GMapProvider.UserAgent = "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1";

seems to work now :-)


Jul 16, 2012 at 4:26 PM

fixed by using integrated pseudo-randomized value ;}

Jul 17, 2012 at 8:56 AM

Hi radioman,

and how can I solve the problem in my application now ?
I'm using the DLLs Version 1.6

Setting (like xandolph) the
     frmMain.GM.GMapProvider.UserAgent = "...."
gives the error message :
    "Access of shared member through an instance; qualifying expression will not be evaluated"

and that it is fixed, as you announced, will help me only if I go into the source and compile it.
Right ?

Sorry for the boring questions

Jul 17, 2012 at 11:39 AM

look above, there are few answers already, no errors, works perfect

Jul 17, 2012 at 12:23 PM


just use the static member, don't try to access an instance of GMapProvider:

GMapProvider.UserAgent = "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1";
Jul 17, 2012 at 12:42 PM

Many thanks radioman, xandolph,

of course I did "look above".

After looking into the source I found the necessary class names:

GMap.NET.MapProviders.GMapProvider.UserAgent = "Mozilla..." 

Jul 19, 2012 at 2:11 PM

Hi all - I, too, have experienced the AccessBlocked message and know the issue to be the default User Agent.

I'm concerned that I may inadvertently breach the correct format of the User Agent string that I intend to specify.

My understanding is that the first token is product, so can I assume I can put what I like in here?

The second token is Layout engine and version. I know that xandolph uses Gecko/20100101 but is this valid for all User Agent strings?
(a quick check on google suggests that a layout engine is a browser-related term, but we're all using GMaps as a .NET component not as a browser component, so should I be using any reference to Gecko?- or is the GMaps .NET component using Gecko behind the scenes?)

Is the third token (extensions) optional?

btw: further up this thread, on June 7, 2010, radioman suggested that we shouldn't use server_only mode unless testing.

A recent post on the OSM help page says the following

 "scraping" use (where you download tiles for storing them rather than for displaying them live in the browser) are not allowed.

so should we really be using

GMapControl1.Manager.Mode = GMap.NET.AccessMode.ServerAndCache?

Jul 20, 2012 at 10:18 AM

yes, if you want slow access, server overload, use server mode

Jul 20, 2012 at 10:29 AM

Radioman, I agree with you entirely, I'm just letting people know that it is technically not permitted and they can make their own minds up

Jul 20, 2012 at 10:37 AM

'they' are helpless, random useragent, they can't even identify this software ;}