why the Gmap is not working with windows -7, 64 bit.

Jul 13, 2010 at 9:59 AM
Edited Jul 13, 2010 at 10:06 AM

 why the Gmap is not working with windows -7, 64 bit.... The map is not coming.we guess that The Sql Lite dll  is not supported.We need SQL Lite DLL.

 

WE have downloaded the 64bit Sql Lite Dll,but that is showing oly the portion of Map.we cannot able to scroll down and view the map. it is static.so we think there might be any configurations missing. so we need SQL Lite Dll 64bit that suit to get the map working fine.

 

 

Can u pls help us.

 

 

 

Coordinator
Jul 13, 2010 at 10:08 AM
Edited Jul 13, 2010 at 10:25 AM

try use right mouse down+dragg ;}

p.s. check http://greatmaps.codeplex.com/documentation 

Jul 13, 2010 at 10:16 AM
Hello, Even I'm having the same problem with windows 7 64 bit.... Left mouse down and drag does not work .... We're using the Windows forms Application... We even tried changing the SQL Lite dll to 64 bit......but we haven't found success yet.... I would appreciate some help,.... Thanks...
Coordinator
Jul 13, 2010 at 10:25 AM

;}

Jul 13, 2010 at 11:01 AM

Thanks For yr reply,

 

I have tried Using Dll as wat u specified in the above post. but still getting the same problem. its not working. it is showing oly the half portion of the map.and when i scroll i got stuck it is not showing the portion which im now.

 

Coordinator
Jul 13, 2010 at 11:20 AM

it works perfect in xp/vista/win7 x86 and x64, you missed something

Jul 13, 2010 at 11:38 AM

I'm not able to upload the screen shots here. The initial image of the map is coming but after scrolling the map image is blank it's not coming. Shall I upload the image in the issue tracker if you want??? Even in the demo  project the initial image is only coming not after scrolling it!!!!  Any idea??? :-(

 

 

 

Regards,

JankCD

 

Coordinator
Jul 13, 2010 at 11:43 AM

what do you mean?

Jul 13, 2010 at 11:56 AM

I mean that I'm getting just the half map the other half or the rest region is not loaded or it's not coming when we scroll just the "BLANK Boxes" are coming . Hope it's clear.

 

 

Regards,

Jankhana

Jul 13, 2010 at 12:04 PM
Hello, right mouse down+dragg doesn't load the rest of the MAP in Windows 7 64 bit Operating System. right mouse down+dragg is not working in Windows 7 64 bit...We tried rebuilding your source too. It is working in WPF....but its Not Working in Windows Forms...Please help... Thanks
Jul 13, 2010 at 12:17 PM

Running on Win7 64 and everything is fine here. Dunno what could it be, but it's not windows itself.

Maybe something else, video drivers or modules or...

Jul 13, 2010 at 12:20 PM
I suspect it has something to do with SQLLITE :( We've tried it on more than 3 different Windows 7 64 bit PCs here.... the scrolling doesn't work...it's the only problem we're facing... On form load,the map loads. After the form loads,unable to view further when we scroll.
Coordinator
Jul 13, 2010 at 12:25 PM

it works perfect on win7, i use it daily, are you sure you set target to x86?

Jul 13, 2010 at 12:38 PM

i have uploaded the screenshots in Issue tracker.please have a look and let us know.

 

Jul 13, 2010 at 1:12 PM
Yes,We have set the target to X86 and even tried removing the build conditions...it still doesn't work
Coordinator
Jul 13, 2010 at 1:27 PM

what version?

Jul 13, 2010 at 1:30 PM
Edited Jul 13, 2010 at 1:31 PM
I'm using Visual Studio 2010 in Windows 7 Professional 64 bit OS. Thanks
Jul 13, 2010 at 1:59 PM

Am using SQLite and GMaps without these issues.

Since you say you can't scroll, i'd look into the mouse events. Not GMaps' own, but your very mouse.

And i would also have a look at the layers if you're using WinForms, or zindex if you're using WPF.

Maybe you put some control over the GMap renderer???

Jul 13, 2010 at 2:06 PM
Edited Jul 13, 2010 at 2:06 PM
WPF version works perfectly fine!! Winforms version also works fine on X86 PC's here... The problem ONLY occurs on 64 bit Operating Systems for Windows Forms Application....it does not occur on 32 bit OSs Thanks
Jul 13, 2010 at 3:21 PM

Ok so i have Gmaps WinForms working together with Win7 Home Premium 64, no problems at all.

Jul 13, 2010 at 3:39 PM
Its not working in Windows 7 Professional 64 bit.... I guess the only option I have is to take a video and send you to prove it.... :-(
Jul 13, 2010 at 3:56 PM

I believe you.

But the fact that Radioman and I (at least) have it working, means that it is not a general problem.

Must be something related to your specific configuration.

Coordinator
Jul 13, 2010 at 4:42 PM

win7 ultimate works, win7 prof. works too, both x64, so it's not win7 version issue