No maps displayed?!

Aug 26, 2010 at 5:49 PM

I am having a problem where none of the Google maps will show.  I have changed mode from 'server and cache' to 'server only', but still won't work.  It works fine on my machine, but we are testing on another machine that it won't work on.  Any ideas on something to check?  All I get now are the blue tiles that tell me the images aren't available at that zoom level.

Aug 26, 2010 at 5:51 PM

- What language are you using? - Which Frameworks are you using?? - What's the code you have to load the map??? Don't think Radioman can tell you either without any info about what you've done.

Coordinator
Aug 26, 2010 at 5:58 PM

sometimes i can, hehe ;} ..but usual problems are just targeting wrong cpu or missing configuration if using .net4

Aug 26, 2010 at 5:59 PM

We are using VB.Net framework 4.0.  I have already made the change to the app.config file to allow it to work with 4.0. 

 

Here is the sub I use to set up the map control:

 

Private Sub SetMapProperties()

        GMapControl1.Size = MPC.Size

        GMapControl1.Location = MPC.Location

        GMapControl1.Dock = DockStyle.Fill

        GMapControl1.ZoomAndCenterMarkers(Nothing)

        UpdateMapSource()       

        GMapControl1.CacheLocation = "C:\ProgramData\Logic Concepts"    

        GMapControl1.MinZoom = 3

        GMapControl1.MaxZoom = 19

        GMapControl1.Zoom = 15

 

        GMapControl1.CurrentPosition = New PointLatLng(33.952647147828451, -84.549941718578339)

        center = New GMapMarkerCross(GMapControl1.CurrentPosition)

        first = New GMapOverlay(GMapControl1, "first")

        objects = New GMapOverlay(GMapControl1, "objects")

        MapTop = New GMapOverlay(GMapControl1, "top")

        GMapControl1.Overlays.Add(first)

        GMapControl1.Overlays.Add(objects)

        GMapControl1.Overlays.Add(MapTop)

        first.Markers.Add(center)

End Sub

 

Coordinator
Aug 26, 2010 at 6:08 PM

are you really calling this in the forms constructor?