2b200490367c failing on build?

Topics: Bugs
Oct 26, 2010 at 3:16 PM
Edited Oct 26, 2010 at 3:17 PM

Not sure why, but when i tried to compile my project using 2b200490367c it fails on compilation with no errors shown... just says  1 failed...

my project is in vb.net if that makes any difference.

I havnt had any problems till i updated from   4487be750c91   to   2b200490367c

switching back to 4487be750c91 allows it to compile again.

Oct 26, 2010 at 4:40 PM

I have just spent the last few hours trying to battle the exact same problem.

My solution was to remove the System.Xml.Linq reference from my project, with this reference in place my solution also did not build and with no errors but previous versions did work fine.

Maybe Radioman will be able to track back to see if a recent change has caused this problem.



Oct 26, 2010 at 6:24 PM


Oct 26, 2010 at 10:31 PM

got the same problem here, I was thinking I was foul :) (maybe am I ? )

Oct 27, 2010 at 6:01 AM

strange problems ;}

Oct 28, 2010 at 6:19 AM

Got the same problem with build 6fdd8b685666.

Seem to work if I remove "System.Xml.Linq" too

Oct 28, 2010 at 6:36 AM

build just fine here with or without System.Xml.Linq ;}

Oct 28, 2010 at 7:37 AM

when I open the example it's building fine too.

But not my application, which I have included the gmaps.net dll

Oct 28, 2010 at 8:13 AM

strange, what version forms/wpf?

Oct 28, 2010 at 8:14 AM

wpf, for me

Oct 28, 2010 at 9:37 AM

When you download this version and build it works fine, but when you add these built references into your winforms VB (VS2010) project it does not build until you remove the Linq reference.

Oct 28, 2010 at 9:45 AM

is it vb specific?

Oct 28, 2010 at 9:48 AM

If someone else does not reply I can try and build a quick c# project later on today.

Oct 28, 2010 at 9:49 AM

I use VB too...

Oct 28, 2010 at 8:24 PM

wpf for the maps but a hybrid app

Nov 2, 2010 at 7:48 AM

Must add my admiration for a fantastic project, radioman!

I have had the same problem and thought it was something I had done.

Using VB as well, and removing System.XML.Linq reference fixes it. I don't use Linq anyway, so no loss, but a strange problem...

Nov 9, 2010 at 4:03 AM

I'm having the same problem. It is only with GMap.NET.Core.dll that I'm having the problem. My project is a VB.Net project in VS2010/.Net 4.0. I removed System.XML.Linq and that fixes the problem. I'm using greatmaps_f3b3d0867108.

Nov 9, 2010 at 8:22 AM

fixed now

Nov 9, 2010 at 1:35 PM

I downloaded greatmaps-bc21f46565cb and recompiled the entire solution in Release mode and then took the GMap.NET.Core.dll from the Build/Release directory and added it to my program. I then added back in the System.XML.Linq assembly and tried compiling. The compiled with no errors. The version of GMap.NET.Core.dll didn't change from when I upgraded the file with the new build. Removing System.XML.Linq allowed my project to compile again.