GMap & Mono run problems

Topics: Help
Jul 9, 2011 at 9:55 PM

Hello!

 

I would like to run GMap in my own app under Linux (Mono).

I can compile GMap normaly, but when i run my App and start the Map, after some minits I receve a "Exception: the request timed out" Exception!

I get also this Messages:

** (/home/rupert/Projekt/ils-simConfig/ils-simConfig/bin/Debug/ils-simConfig.exe:6820): WARNING **: Missing method .ctor in assembly /usr/lib/mono/gac/System/2.0.0.0__b77a5c561934e089/System.dll, type Mono.Security.Protocol.Tls.CertificateValidationCallback2

** (/home/rupert/Projekt/ils-simConfig/ils-simConfig/bin/Debug/ils-simConfig.exe:6820): WARNING **: The class Mono.Security.Protocol.Tls.CertificateValidationCallback2 could not be loaded, used in System

When I try to compile and run your source (Demo App), I receve a "Unhandled Exception: System.IO.FileNotFoundException: Could not find file "/home/rupert/.local/share/GMap.NET/TileDBv5/en/Data.gmdb"." Exception and the programm is closing. (PreCompiled Programm is normal working!)

Do you have any ideas? Do I have to cange any compile settings? (I have tried it with MonoDevelop)

 

Thx, Peter

Jul 9, 2011 at 10:29 PM
Edited Jul 10, 2011 at 11:36 AM

yes, when compile mono version, you must change compilation symbols in Core and Demo project:

MONO_disabled -> MONO 

..and i don't test mono version very often so it might be out of sync from time to time ;} help is welcome

Jul 9, 2011 at 10:52 PM

thx for the reply

I have set the symbols already to: TRACE;DEBUG;MONO; MySQL_disabled; PostgreSQL_disabled; SQLite

you have uploaded on 4. May a working Mono version.. I will try to compile this version and see if this is running, maybe this will work... :)

Jul 10, 2011 at 12:18 AM

I have found a very funy answer to this problem:

when I compile my program (or yours), the compiler is creating this files too:

* Mono.Data.SqliteClient.dll

* Mono.Security.dll

* Npgsql.dll

when I delete, or cut this files, all is working corectly, but when the are in the same folder as the exe I will get the Exception!

 

I have tried every dll from the dir, the problem is on Mono.Security.dll. If I del this file, all is ok ;)

Jul 10, 2011 at 8:48 AM

i see, well these dll are from windows ;} makes sense

Jul 10, 2011 at 11:36 AM

..and there was few incompatibilities, I've just fixed them, also when you build the demo, there is compilations symbols too

Jul 13, 2011 at 12:46 AM

Hy radioman!

thx for the very fast update!

the new version is working very good with Mono!

 

I have just some incompatiles found with Linux: (Pathname with little characters) BSE.WindowsForms - Resources.resx:

Line 137: ..\Resources\Collapse.jpg

Line 140: ..\Resources\Collapse_h.jpg

Line 143: ..\Resources\Expand.jpg

Line 146: ..\Resources\Expand_h.jpg