GDI+ error in latest build (Sun 10-July)

Topics: Bugs
Jul 12, 2011 at 11:45 AM

I have downloaded the latest build and get a GDI+ error when i set the map type

to either BING or GOOGLE .    (at line 546 in GMapControl.cs )

I only have .NET v4 loaded on this machine with VS2010 and

chose to target .NET v4 by the project converter when opening the project.

I have used other builds of Gmap without problems.

Thanks,

Paul

 

Coordinator
Jul 12, 2011 at 5:00 PM

works just fine for me, what OS, CPU target?, should with any

Jul 12, 2011 at 5:35 PM

OS is   XP SP3,    CPU  is ANY

BindMapOld  is ok,    but change to BingMap  and it crashes with that GDI+ message.

GoogleMap is ok,  but GoogleSattelliteMap  also crashes.  

Very stange, just running the WinFormsDemo  without any changes at all.

Just tried it also with the July 5th Build,,       68aa556d13c1,  and that too craches if i select any of the satellite sourced maps?

 

 

Coordinator
Jul 12, 2011 at 5:52 PM

works fine for me ;} are you using cached data or fresh from server?

Jul 14, 2011 at 2:01 PM

Still getting the same error.

Ive build a virtual machine now, put VS2010 with CR2010 on it.   Open your build  ea1071d1c5db    simply run it's ok, then run and change the google maps to GOODLE satellitette.

Then the GDI+ Error message comes.

Coordinator
Jul 14, 2011 at 2:06 PM

i didn't test it on VM, maybe

Jul 14, 2011 at 2:14 PM

then have you changed anything in the GDI routines ???? since i have always developed within a VM and

have never has this problem before with GMAP.

Coordinator
Jul 14, 2011 at 2:21 PM

i've turned off image validation, it improves loading times, you can try enable it and test again

it's in WindowsFormsImageProxy

...

Image m = Image.FromStream(stream, true, false);

Jul 14, 2011 at 2:38 PM

It works now with that setting turned back on,  re-tested with it off error, tested with it on , works fine.

So now, how to detect if that needs to be TRUE/FALSE in code at runtime, so i don't have to keep changing your source codes with

build releases   ???

 

Thanks,

 

Coordinator
Jul 14, 2011 at 2:43 PM

if i don't find solution, i'll add some property to turn validation on manualy

Jul 15, 2011 at 6:27 PM

I have the same GDI+ error if using GoogleSattelliteMap

My OS is WinXP SP3 with CPU any and VS2008

thanks for the hint with validation flag, setting it to true solved the problem

Coordinator
Jul 15, 2011 at 6:34 PM
Edited Jul 15, 2011 at 6:35 PM

do you use .net2 or .net2sp1?

Aug 12, 2011 at 6:17 AM

I have the same error on winxp sp3,but it's good on win7!!!

Coordinator
Aug 13, 2011 at 12:14 PM

you can check the latest build again, should be working fine on xp now