Simple Solution For Running x86 and x64 platforms ;)

Topics: General
Oct 21, 2011 at 9:02 PM

I'm new about GMap.Net and i tried afew solution about running Gmap apps on both platform(x86 and x64) but thats not a answer for me. All problem about SQLite.DLL

And i use this solution and it's WORKED :).

Tip : If you use System.Data.SQLite.DLL same name on project you will get problem.

I created 2 folder x86, x64 and i renamed DLLs like it

  • {App_FOLDER}/x86/System.Data.SQLitex64.DLL
  • {App_FOLDER}/x64/System.Data.SQLitex64.DLL

Add this code beforede initialize the GMap.

 

string dir = AppDomain.CurrentDomain.BaseDirectory + (IntPtr.Size == 8 ? "x64" : "x86") + Path.DirectorySeparatorChar;
File.Copy((dir + "System.Data.SQLite" + (IntPtr.Size == 8 ? "x64" : "x86") + ".dll"), AppDomain.CurrentDomain.BaseDirectory + "System.Data.SQLite.DLL", true);


Regards, Cagatay ONCUL

 

Coordinator
Oct 21, 2011 at 9:38 PM

..to bad it's already solved internally, you don't need to do anything, it's just works, but thanks anyway ;}

Oct 21, 2011 at 9:46 PM

I downloaded latest version of GMAP but it doesnot work on X86 platforms. I tried to include x86 x64 folders(which is getting with download). Thats only working project when the compiled computers platform. If u use x86 and compile app, it can be running only x86 platform. But if you use x64 platform and compile the project your binary project only working on x64 platform. I search alotof discussion but i found nothing ;) thank you again.

Coordinator
Oct 21, 2011 at 9:50 PM

;} did you tried AnyCPU? ;}

Oct 21, 2011 at 9:55 PM

Yes i tried AnyCPU and working. But if you copy your binary project to other platform types , you will get BLUE screen on map. I wasted 4 hours for this problem :)

Coordinator
Oct 21, 2011 at 9:57 PM

nonsense

Coordinator
Oct 21, 2011 at 10:46 PM

works fine on any cpu / any target / any framefork version without any configs or recompilation: