Unable to execute the demo from office, WebProxy

Topics: General
Feb 9, 2012 at 5:05 PM

Hi, I am unable to execute the demo application or the source code from office, from office it always displays error, but from home internet it always worked. Can you suggest me something...

 

Thanks

Coordinator
Feb 9, 2012 at 7:03 PM

nop

Feb 10, 2012 at 9:04 AM

Maybe, you need to change the proxy settings ?

In the Winform test application, I have changed the following lines :

MainMap.Manager.Proxy = new WebProxy("10.2.0.100", 8080);
MainMap.Manager.Proxy.Credentials = new NetworkCredential("ogrenci@bilgeadam.com", "bilgeada");

with :

MainMap.Manager.Proxy = WebRequest.GetSystemWebProxy();
MainMap.Manager.Proxy.Credentials = CredentialCache.DefaultNetworkCredentials;

Feb 10, 2012 at 10:48 AM
bfab wrote:

Maybe, you need to change the proxy settings ?

In the Winform test application, I have changed the following lines :

MainMap.Manager.Proxy = new WebProxy("10.2.0.100", 8080);
MainMap.Manager.Proxy.Credentials = new NetworkCredential("ogrenci@bilgeadam.com", "bilgeada");

with :

MainMap.Manager.Proxy = WebRequest.GetSystemWebProxy();
MainMap.Manager.Proxy.Credentials = CredentialCache.DefaultNetworkCredentials;

Thanks bfad,  your suggestion worked. but just to let new comers know that I am using the latest version in which the upper lines did't work.

So search the below lines which would in the constructor of MainForm

 

//GMapProvider.WebProxy = new WebProxy("10.2.0.100", 8080);
//GMapProvider.WebProxy.Credentials = new NetworkCredential("ogrenci@bilgeadam.com", "bilgeada");

and replace them with

  GMapProvider.WebProxy = WebRequest.GetSystemWebProxy();
  GMapProvider.WebProxy.Credentials = CredentialCache.DefaultCredentials;

 

Thanks