application load and map source changing

Topics: Etc...
May 1, 2013 at 9:01 AM
hi
when the main form is loading it takes so much time to load
why?
when i switch to another map type it takes so much time for the first time
what should i do?
thanks
Coordinator
May 1, 2013 at 9:17 AM
you probably use debug build
May 1, 2013 at 9:40 AM
radioman wrote:
you probably use debug build
no
i have used release build
and my map database is about 2 gb with 2 map type of google map and google hybrid
Coordinator
May 1, 2013 at 9:47 AM
witch cache it loads instantly, i don't know what are you doing there...
May 1, 2013 at 10:55 AM
radioman wrote:
witch cache it loads instantly, i don't know what are you doing there...
I'm just using a simple winform form with gmapcontrol on it
May 4, 2013 at 6:57 AM
Isn't it because of the size of cache map file ?
Coordinator
May 5, 2013 at 1:35 PM
nop
May 6, 2013 at 11:51 AM
radioman wrote:
nop
so why this happens?

it happens just when i assign the GOOGLEMAP like below code at the beginning of form initialization
gMapControl1.MapProvider = GMapProviders.GoogleMap;
May 6, 2013 at 12:11 PM
i tested the demo application with the 2 GB map database
and the result is that demo applications takes times to load (about 20 seconds)
what should i do?
Coordinator
May 6, 2013 at 1:06 PM
you use debug build, use release build
May 7, 2013 at 7:23 AM
used release build
but the problem is happening
Coordinator
May 7, 2013 at 7:24 AM
what version do you use?
May 7, 2013 at 9:41 AM
radioman wrote:
what version do you use?
greatmaps-5f3f706f71e8
Jun 8, 2013 at 10:35 AM
did you fix the problem?
Coordinator
Jun 10, 2013 at 11:50 AM
there is no problem
Jun 10, 2013 at 1:28 PM
radioman wrote:
there is no problem
so, why it takes too much time to change the map source from google map to google hybrid map?
Coordinator
Jun 10, 2013 at 1:36 PM
investigate, do some debugging, maybe it's system specific
Jun 10, 2013 at 5:47 PM
radioman wrote:
investigate, do some debugging, maybe it's system specific
i have tested it on 4 different system.
but all of them takes some times to load.
my gmdb is around 2.3 GB
and it takes 30 seconds to load the application
is it normal?
Coordinator
Jun 10, 2013 at 6:41 PM
turn the freaking debugger on ;}
Jun 10, 2013 at 7:07 PM
radioman wrote:
turn the freaking debugger on ;}
what it means?
i don't know how to do that
could you please explain more?
thanks