WPF & VS 2010

Topics: WPF
Aug 23, 2010 at 7:57 PM
Edited Aug 23, 2010 at 7:58 PM

Hi there!

First of all, this is a great project! Keep up the good work!
However, I have some problems creating a first application with it.

Can you please tell me what I am doing wrong?

  • creating a new C# WPF 4.0 app in VS 2010 on x64 CPU.
  • adding references to GMap.NET.Core.dll, GMap.NET.WindowsPresentation.dll, System.Data.SQLite.DLL
  • trying to add the control via Toolbox -> Choose Element -> WPF Components -> point to GMap.NET.WindowsPresentation.dll:
    Then it says (translated):
    "The assembly "GMap.NET.WindowsPresentation, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b85b9027b614afef" could not be loaded. Maybe this assembly was downloaded, see http://go.microsoft.com/fwlink/?LinkId=179545"

Opening the sample projects does not work too. After the conversion to VS 2010 there are two errors concerning the OutputPath (which is set to x86). Additionally there are two warnings, where it says that it can't find GMap.NET.WindowsPresentation and GMap.NET.Core.
Do you have any ideas what I am doing wrong?

Thank you in advantage!

 

Aug 24, 2010 at 9:02 AM

set target to x64 and use sqlite dll version  of x64, (GMap.NET\References\Windows\x64)

Aug 24, 2010 at 9:37 AM

Thank you for your fast response!

I set target to x64 and included the x64 sqlite, but I encounter some problems, i.e. after that (or in your demo projects as well) i can not add any other reference because the window is not loading in VS 2010. It is very strange. I were not able to get the control to the toolbar because of that. Neither I could build the WPF demo apps myself.
What the hell am I doing wrong?? :(

Aug 24, 2010 at 9:59 AM
Edited Aug 24, 2010 at 10:00 AM

;} i've no idea, but check http://greatmaps.codeplex.com/documentation

Aug 24, 2010 at 10:06 AM

Thank you again!

I tried what I could from the documentation concerning x64 :(

Is there a x64 WPF VS 2010 Sample from anyone that I just can ... launch maybe?

Aug 24, 2010 at 11:08 AM

did you set config file, target? There is nothing more, it just works

Aug 24, 2010 at 11:39 AM

I set the config file again, it was discarded, I don't know why.

But it is all the time saying:
"The assembly "GMap.NET.WindowsPresentation, Version=1.0.0.0, Culture=neutral, PublicKeyToken=b85b9027b614afef" could not be loaded. Maybe this assembly was downloaded, see http://go.microsoft.com/fwlink/?LinkId=179545"

Thank you for your patience!

Aug 24, 2010 at 11:47 AM

what is your cpu target?

Aug 24, 2010 at 11:50 AM

In Project Properties it is set to x64 and I use the sqlite x64 dll as suggested!
Is that wrong? :/

Aug 24, 2010 at 11:52 AM

Project Properties?

Aug 24, 2010 at 11:54 AM

when you click on Project in the menubar and then Properties -> Build -> Target Plattform)!

Aug 24, 2010 at 11:58 AM

is it the same target as next to green debug arrow?

Aug 24, 2010 at 12:21 PM

I switched my VS layout to c# development so I now have this arrow. I said in there target: x64 copy from: x86. No change in behaviour after that :(

Aug 24, 2010 at 12:28 PM

does the demos even run?

Aug 24, 2010 at 12:30 PM

Your Demo.WindowsPresentation.exe does run fine! Out of the IDE - no :(

Aug 24, 2010 at 1:26 PM

in demo you must set target to x86, thats the default configuration

Aug 27, 2010 at 8:15 PM

ShadowMare, locate the Gmap.Net dlls you downloaded and are referencing, right-click on them and check to see if there is a security warning at the bottom. You'll have to click the "Unblock" button.